[Libtorrent-devel] libtorrent-0.11.9 configure failed

Josef Drexler josef at ttdpatch.net
Thu Oct 30 11:18:05 UTC 2008


On Oct 30, 2008, at 5:00 AM, 李海红 wrote:
>    My purpose is to import rtorrent to my arm-uclinux  
> platform,kernel is 2.4.26.
> first,  I see the README tell me I required:
>   libsigc++ 2.0 (deb: libsigc++-2.0-dev)
>   g++ >= 3.3
> and on my linux pc Federo Core 4,I have only gcc 2.95.3. So I  
> download a new gcc version 3.4.0:

OK, 3.4.x should work fine, although 4.x would be better (improved  
optimizations).

> ./configure --host=arm-elf --enable-aligned CC=/root/bin/arm- 
> uclinux-tool/bin/arm-elf-gcc

You're setting CC here, but that's for the C compiler. You need the C+ 
+ compiler g++ which you set with CXX.

> configure:24292: arm-elf-g++ -c -g -O2 -g -DDEBUG -I/usr/kerberos/ 
> include   -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/ 
> include    conftest.cpp >&5
> conftest.cpp: In function `int main()':
> conftest.cpp:3: call of overloaded `f (int *&)' is ambiguous

So this here is probably using the old g++ 2.95 that is on your system.

> it seemed the compiler miss something.
> btw,the download gcc-3.4.0 above in directory /root/bin/arm-uclinux- 
> tool/lib/gcc/arm-uclinux/3.4.0/, don't have crt0.o,libc.a,I copy  
> both from other gcc versions,if don't have it ,other errors will  
> occur.

Copying those files from a different compiler version (ESPECIALLY a  
different major version 2.x -> 3.x) is very likely to break compiled  
programs. You MUST use the files that go with the specific compiler  
version. Your distribution should have a download for these files, as  
well as a download for g++ 3.4 which you need as well.

If not, you will have to build your own version of g++ by compiling  
it from source. In that case, I would strongly recommend to get  
version 4.2.x.

-- 
Josef Drexler
josef at ttdpatch.net


More information about the Libtorrent-devel mailing list